1. Skip to Menu
  2. Skip to Content
  3. Skip to Footer>
Friday May 3rd     10:35 PM PDT                                  

Flash Plugin for Firefox on FreeBSD

PDF Print E-mail

Written by Greg King Sunday, 05 September 2010 00:00

The Adobe Flash plugin for Firefox allows us to view feature rich, interactive websites.  While this process is not nearly as intensive as installing Java was, we will need to compile and install Linux Binary support.


First, let's install the linux binary support and configure it to load at boot time.

# cd /usr/ports/emulators/linux_base-f10

# make install clean

If you get an error saying : linux_base-f10-10_2 linuxulator is not (kld)loaded. then you did not load the linux compatibility when installing the FreeBSD system... follow these steps and then try the above again.  If you didn't get that error, skip down to "Load Linux Emulator at Boot Time".

# cd /usr/src/sys/modules/linux
# make
# make install
# make clean
# echo 'linux_enable="YES"' >> /etc/rc.conf
# kldload linux


Load Linux Emulator at Boot Time


# nano /etc/fstab

paste the following line into the file and save it.  Ensure the line does not break to the next line or you will have problems booting!

linproc                 /usr/compat/linux/proc  linprocfs       rw              0       0

Now, we will mount linproc and start the emulator

# mount linproc
# /etc/rc.d/abi start
# /etc/rc.d/sysctl restart

Now we need to install the linux wrapper for our plugin.

# cd /usr/ports/www/nspluginwrapper
# make install clean

Now we have to compile our plugin.

# cd /usr/ports/www/linux-f10-flashplugin10
# make install clean

next  we set up a symbolic link to the plugin


# ln -s /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so  /usr/local/lib/browser_plugins/

and finally, we install the plugin for our user (Note:  This has to be done for each desktop user wanting FLASH support on their browser!)

The easiest way to do this is to first find where the .so file was installed.

# find / -name libflashplayer.so

Look for a line that does NOT show SYMLINK in the path.  In my case, it is
/usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so

Now change to your user, and add the plugin above to your user's profile by doing the following (change the path in the nspluginwrapper command to match yours).

# su - <user>


% nspluginwrapper -v -i /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so


Restart Firefox and go to about:plugins and verify the SHOCKWAVE FLASHPLAYER plugin is installed.

To test it, go to http://puzzles.usatoday.com/?POE=UCNCW and verify the crossword puzzle loads.

  FreeBSD Goodies
eXTReMe Tracker
Content View Hits : 405197