Misc Stuff
DISCLAIMER! This document is nothing more than the musings of the author as he attempts to perform the stated tasks. Conclusions and approaches
may very well be incorrect, inefficient, or otherwise outside of professionally accepted best practices. Use this document at your own risk! In this
document, screen outputs will be presented in green. Where keyboard input is required, the prompt will be in bolded red. # means you should be at the
super user prompt, $ means you should be at an unprivileged user prompt. Do not include these prompts in your input! The command to be typed will be
shown in blue.
# ls -al
means you type ls -al at the super user prompt.
REMOTE GRAPHICS (Xserver)
I run Debian on my main *nix workstation (referred to as Debian here), so I had to enable xserver over tcp/ip on Debian. To do this, I edited Debian's /usr/share/gdm/gdm.schemas and searched for the schema (<key>security/DisallowTCP</key>) that controls tcp/ip connections. I set the schema to false and rebooted the Debian box.
When Debian was back online, I opened a terminal window and typed xhost +, then I ssh'd over to the Solaris box, went to root, and typed
When Debian was back online, I opened a terminal window and typed xhost +, then I ssh'd over to the Solaris box, went to root, and typed
# export DISPLAY=debian:0.0 (use the ip address of 'debian' if it is not in your host table).
then I ran xclock
# /usr/openwin/bin/xlock
I had a nice little graphical clock show up on my debian desktop!
UPDATING FIREFOX
The as installed version of Firefox on Solaris 10 is the 3.x series which is full of security bugs. We will uninstall the old version and install the new 15.0.1 version.I uninstalled Firefox by first determining what packages it installed from
# pkginfo |grep firefox
I then removed the packages, one at a time
# pkgrm <package>
until the pkginfo found no more instances.
I downloaded the current Solaris Sparc firefox from the link on the obtaining software packages. I had to bunzip2 the file, put the unzipped package in my /cots directory and
# pkgadd -d ./<package>
The I created a symbolic link from the original location of the binary file to the new location. I did this so I didn't have to mess with all of the graphical links on a user's desktop.
# ln -s /opt/sfw/lib/firefox/firefox /usr/bin/firefox
now to run firefox from remote, on the local side, issue a xhost +, then ssh over to the solaris box, export your display back to the local box and run firefox.
SMCWEBSERVER
By default the Solaris Management Console Webserver (smcwebserver) only listens on the local host. I like to use the webserver remotely, so needed to update the service to listen on the ethernet cards. This is how to perform the step:# svccfg
svc:> select system/webconsole
svc:/system/webconsole> setprop options/tcp_listen=true
svc:/system/webconsole> quit
# /usr/sbin/smcwebserver restart
If the console service isn't set to run at startup, you can enable it by doing this:
# /usr/sbin/smcebserver enable